VAMP SDK

Video Ad Mediation Platform Software Development Kit

maioの統合


このガイドではiOSアプリにVAMP SDKのmaioアダプターを導入する方法について説明します。

最新のアダプター

現在リリースされているVAMPMaioAdapterの最新バージョンはこちらになります。

Note

アダプターによってサポートされているOSバージョンでも、VAMP SDKによってサポートされているOSバージョンでなければ、広告を表示をすることはできません。

最新アダプターバージョン 対応アドネットワークバージョン 最低サポートOS 更新日
2.1.2.0 2.1.2
[公式リリースへ]
iOS14 2024-01-22

CocoaPodsでアダプターをインストール

まずは、CocoaPodsでアダプターをインストールします。

プロジェクトのPodfileに以下の行を追加します。

pod 'VAMPMaioAdapter'

バージョンを指定する場合は以下のようにします。

pod 'VAMPMaioAdapter', "[VERSION]"

依存フレームワーク

maio SDKは以下のフレームワークに依存しています。

  • AdSupport
  • AVFoundation
  • CoreMedia
  • Foundation
  • MobileCoreServices
  • SystemConfiguration
  • StoreKit
  • UIKit
  • WebKit
  • libz

VAMPMaioAdapterの更新履歴

Version 2.1.2.0(2024-01-22)

  • maio SDK 2.1.2(2024-01-19更新)と互換性があります。
  • iOS 17において、まれにアプリ内ストアを閉じたあと操作できなくなる場合がある現象を修正しました。
  • 特定の状況下において、広告ロード時にクラッシュする場合がある問題を修正しました。

Version 2.1.1.0(2023-11-07)

  • maio SDK 2.1.1と互換性があります。
  • maio SDK v2のメジャーアップデート対応。Supported: iOS 14.0+ (Xcode 14.1+)。※古いiOSバージョン対応が必要な場合は1.6系を利用ください。
  • 更新内容(2023-10-11):MaioVersion が適切な値を返すように修正しました。

Version 1.6.3.2(2023-10-18)

  • maio SDK 1.6.3と互換性があります。
  • VAMPmaioAdapterのみアップデート

Version 1.6.3.1(2023-07-13)

  • maio SDK 1.6.3と互換性があります。

Version 1.6.3.0(2022-11-07)

  • maio SDK 1.6.3と互換性があります。
  • maio変更内容2022年10月28日:排他制御の問題で、一部予期せぬクラッシュが発生する問題に対応しました。

Version 1.6.2.0

  • maio SDK 1.6.2と互換性があります。

Version 1.6.1.0

  • maio SDK 1.6.1と互換性があります。

Version 1.6.0.1

  • maio SDK 1.6.0と互換性があります。

Version 1.6.0.0

  • maio SDK 1.6.0と互換性があります。
  • VAMP SDK v4.3.0以上が必要です。

Version 1.5.8.1

  • maio SDK 1.5.8と互換性があります。
  • VAMP SDK v4.3.0以上v4.4.0未満が必要です。

Version 1.5.6.0

  • maio SDK 1.5.6.0と互換性があります。
  • VAMP SDK v4.1.0.1以降が必要です。