VAMP SDK

Video Ad Mediation Platform Software Development Kit

Pangleの統合


このガイドではiOSアプリにVAMP SDKのPangleアダプターを導入する方法について説明します。

最新のアダプター

現在リリースされているVAMPPangleAdapterの最新バージョンはこちらになります。

Note

アダプターによってサポートされているOSバージョンでも、VAMP SDKによってサポートされているOSバージョンでなければ、広告を表示をすることはできません。

最新アダプターバージョン 対応アドネットワークバージョン 最低サポートOS 更新日
5.7.0.8.0 5.7.0.8
[公式リリースへ]
iOS12 2024-02-20

CocoaPodsでアダプターをインストール

まずは、CocoaPodsでアダプターをインストールします。

プロジェクトのPodfileに以下の行を追加します。

pod 'VAMPPangleAdapter'

バージョンを指定する場合は以下のようにします。

pod 'VAMPPangleAdapter', "[VERSION]"

プロジェクトの設定

プロジェクトplistファイルでApp Transport Security Settingsを追加するには、まず左側の展開矢印をクリックし、さらに右側のプラスマークをクリックしてAllow Arbitrary Loadsオプションを追加し、値をYESに設定します。

App Transport Security Settings

Note

Pangle SDK APIは全HTTPSをサポートしていますが、広告主のクリエイティブが非HTTPSの場合もあります。

Source Codeで設定する場合は、以下を記述してください。

<key>NSAppTransportSecurity</key>
<dict>
<key>NSAllowsArbitraryLoads</key>
<true/>
</dict>

依存するフレームワーク

Pangle SDKは以下のフレームワークに依存しています。

  • StoreKit.framework
  • MobileCoreServices.framework
  • WebKit.framework
  • MediaPlayer.framework
  • CoreMedia.framework
  • AVFoundation.framework
  • CoreTelephony.framework
  • SystemConfiguration.framework
  • AdSupport.framework
  • CoreMotion.framework
  • Accelerate.framework
  • libresolv.9.tbd
  • libc++.tbd
  • libz.tbd
  • libsqlite3.tbd
  • libbz2.tbd
  • libxml2.tbd
  • libiconv.tbd
  • libc++abi.tbd (newly required from sdk v3.5.0.0)
  • Security.framework

VAMPPangleAdapterの更新履歴

Version 5.7.0.8.0(2024-02-20)

  • Pangle SDK 5.7.0.8と互換性があります。
  • 【重要】5.7.0.8/5.8.0.6以降から新たにPrivacy Manifestを対応しました。新規Privacy Manifest対応しました。その他のバグが修正されました。

Version 5.7.0.6.0(2024-01-04)

  • Pangle SDK 5.7.0.6と互換性があります。
  • Pangle修正内容(2023-12-28)ログ報告の最適化を行いました。広告フォーマットの最適化を行いました。その他のバグが修正されました。

Version 5.6.0.7.0(2023-12-11)

  • Pangle SDK 5.6.0.7と互換性があります。
  • Pangle修正内容(2023-11-30)PAGWKWebViewClientが稀にクラッシュする問題を修正しました。その他のバグが修正されました。

Version 5.4.1.1.1(2023-10-18)

  • Pangle SDK 5.4.1.1と互換性があります。
  • VAMPPangleAdapterのみアップデート

Version 5.4.1.1.0(2023-09-11)

  • Pangle SDK 5.4.1.1と互換性があります。
  • Pangle修正内容(2023-09-07)endcardプリロードされたwebviewのクラッシュ問題を修正する。その他のバグが修正されました。

Version 5.3.1.2.0(2023-07-31)

  • Pangle SDK 5.3.1.2と互換性があります。
  • Pangle修正内容(2023-7-27)schemeに’_‘が含まれている修正問題。その他のバグが修正されました。

Version 5.2.0.8.0(2023-06-05)

  • Pangle SDK 5.2.0.8と互換性があります。
  • Pangle修正内容(2023-06-01)その他のバグが修正されました。

Version 5.2.0.6.0(2023-05-22)

  • Pangle SDK 5.2.0.6と互換性があります。
  • Pangle修正内容(2023-05-18)PAGVideoAdView deallocのcrash問題を修正。その他のバグが修正されました。

Version 5.1.0.6.0(2023-03-28)

  • Pangle SDK 5.1.0.6と互換性があります。
  • Pangle修正内容(2023-03-24)循環参照の修正によりTIP中間ページが解放されない。修復がダイレクトドロップページに入る前にloadingページが表示されていません。その他のバグが修正されました

Version 5.0.1.0.0(2023-03-23)

  • Pangle SDK 5.0.1.0と互換性があります。
  • Pangle修正内容(2023-03-16)Landingページ遷移する際にLoading動画続いて表示されるの不具合を修正しました。その他のバグが修正されました

Version 4.9.1.1.0(2023-02-14)

  • Pangle SDK 4.9.1.1と互換性があります。
  • Pangle修正内容(2023-02-09)その他のバグが修正されました

Version 4.9.1.0.0(2023-02-07)

  • Pangle SDK 4.9.1.0と互換性があります。
  • Pangle修正内容(2023-02-03)その他のバグが修正されました

Version 4.9.0.9.0(2023-01-12)

  • Pangle SDK 4.9.0.9と互換性があります。
  • Pangle修正内容(2023-01-11)その他のバグが修正されました

Version 4.9.0.8.0(2023-01-05)

  • Pangle SDK 4.9.0.8と互換性があります。
  • Pangle修正内容(2023-01-05)その他のバグが修正されました

Version 4.9.0.7.0(2023-01-04)

  • Pangle SDK 4.9.0.7と互換性があります。
  • Pangle修正内容(2022-12-30)その他のバグが修正されました

Version 4.9.0.6.0(2022-12-26)

  • Pangle SDK 4.9.0.6と互換性があります。
  • Pangle修正内容(2022-12-22)画面遷移できない不具合を修正しました。BannerとNative広告表示できない不具合を修正しました。その他のバグが修正されました。

Version 4.8.1.0.0(2022-12-12)

  • Pangle SDK 4.8.1.0と互換性があります。
  • Pangle修正内容(2022-12-08)dsp横画面表示の例外を修正。その他のバグが修正されました

Version 4.8.0.9.0(2022-12-01)

  • Pangle SDK 4.8.0.9と互換性があります。
  • Pangle修正内容(2022-11-30)dsp htmlの時折のロード失敗の問題を修正。その他のバグが修正されました

Version 4.8.0.7.0(2022-11-21)

  • Pangle SDK 4.8.0.7と互換性があります。
  • Pangle修正内容(2022-11-18)CoreLocation と MapKit の依存関係を削除する。アラビア語地域の横画面プレーヤーの全画面ボタンの間隔を修正。その他のバグが修正されました

Version 4.8.0.6.0(2022-11-09)

  • Pangle SDK 4.8.0.6と互換性があります。
  • Pangle修正内容(2022-11-04)SKStoreProductViewController のクラッシュの問題を修正。Pangle sdk と unity sdk を同時に統合することで発生するクラッシュの問題を修正。その他のバグが修正されました

Version 4.8.0.5.0(2022-11-07)

  • Pangle SDK 4.8.0.5と互換性があります。
  • Pangle修正内容(2022-11-04)SKStoreProductViewController のクラッシュの問題を修正。Pangle sdk と unity sdk を同時に統合することで発生するクラッシュの問題を修正。その他のバグが修正されました

Version 4.7.0.6.0(2022-10-04)

  • Pangle SDK 4.7.0.6と互換性があります。
  • Pangle修正内容(2022-09-29)その他のバグが修正されました

Version 4.7.0.4.0(2022-09-20)

  • Pangle SDK 4.7.0.4と互換性があります。
  • Pangle修正内容 [PAGMMAPStorage save] クラッシュを修正。その他のバグが修正されました

Version 4.6.2.2.0(2022-08-30)

  • Pangle SDK 4.6.2.2と互換性があります。

Version 4.6.1.9.0(2022-08-23)

  • Pangle SDK 4.6.1.9と互換性があります。

Version 4.5.2.8.0(2022-07-21)

  • Pangle SDK 4.5.2.8と互換性があります。

Version 4.5.2.7.0(2022-07-14)

  • Pangle SDK 4.5.2.7と互換性があります。

Version 4.5.2.5.0

  • Pangle SDK 4.5.2.5と互換性があります。

Version 4.5.2.4.0

  • Pangle SDK 4.5.2.4と互換性があります。

Version 4.5.2.3.0

  • Pangle SDK 4.5.2.3と互換性があります。

Version 4.3.1.9.2

  • Pangle SDK 4.3.1.9.2と互換性があります。

Version 4.3.1.9.1

  • Pangle SDK 4.3.1.9.1と互換性があります。

Version 4.3.1.9.0

  • Pangle SDK 4.3.1.9と互換性があります。

Version 4.3.0.5.0

  • Pangle SDK 4.3.0.5と互換性があります。

Version 4.2.5.6.0

  • Pangle SDK 4.2.5.6と互換性があります。

Version 4.2.5.3.0

  • Pangle SDK 4.2.5.3と互換性があります。

Version 4.2.0.2.0

  • Pangle SDK 4.2.0.2と互換性があります。

Version 3.9.0.8.0

  • Pangle SDK 3.9.0.8と互換性があります。

Version 3.8.1.0.0

  • Pangle SDK 3.8.1.0と互換性があります。

Version 3.7.0.5.0

  • Pangle SDK 3.7.0.5と互換性があります。

Version 3.5.1.2.0

  • Pangle SDK 3.5.1.2と互換性があります。
  • サポートOSバージョンをiOS10に変更しました。

Version 3.4.2.8.0

  • Pangle SDK 3.4.2.8と互換性があります。
  • VAMP SDK v4.1.0.1以降が必要です。